Wednesday 26th September 2018

Update of the digitalisation platform API (DEP), scheduled 2 years ago

In preparation of the coming release of WinBooks Connect 2.8, the DEP api will be updated to improve some existing features.

The following downtime are expected:

  • DEP Soap API: 5 minutes
  • DEP Rest API: 0 minutes
  • Workers: 10 minutes

Update:

  • 22:30: we start the update. The Soap API, Soap backend services are stopped during the update. The pool A of Rest API servers is also set in maintenance.
  • 22:45: all API's (Soap/Rest) and Soap backend services are up and running (including the pool B of Rest API servers). We start the update of Rest workers and Mail-to
  • 23:00: 1 node of workers is up and running. Updating the second.
  • 23:05: all nodes of workers are up and running. We can now validate the update.
  • 23:10: An issue that doesn't exist in our staging environment has been detected in Mail-To MyDesk: the webhook expected by WinBooks Connect is malformed. We are investigating the cause.
  • 23:36: The source of the bug has been found and fixed. The pending documents are requeued.
  • 23:40: All documents blocked by the bug have been succesfully requeued and imported by WinBooks Connect api.
  • 23:45: The update is finished.